Modern compilers required [Activities after 4.9]

  • user warning: Table './drupal_wetnet/wetnet_comments' is marked as crashed and should be repaired query: SELECT COUNT(*) FROM wetnet_comments c WHERE c.nid = 5902 AND c.status = 0 in /srv/www/domains/wetnet.net/htdocs/modules/comment/comment.module on line 991.
  • user warning: Table './drupal_wetnet/wetnet_comments' is marked as crashed and should be repaired query: SELECT c.cid as cid, c.pid, c.nid, c.subject, c.comment, c.format, c.timestamp, c.name, c.mail, c.homepage, u.uid, u.name AS registered_name, u.signature, u.signature_format, u.picture, u.data, c.thread, c.status FROM wetnet_comments c INNER JOIN wetnet_users u ON c.uid = u.uid WHERE c.nid = 5902 AND c.status = 0 ORDER BY c.thread DESC LIMIT 0, 50 in /srv/www/domains/wetnet.net/htdocs/modules/comment/comment.module on line 991.
n7ipb's picture

After the KDE SC 4.9 is released, projects inside KDE Projects: Activities will start requiring more up-to-date compilers and will start (ab)using more modern C++.

For the library, the requirement will be GCC 4.6, clang 3.0 or whatever version of MSVC++ has the equivalent features. GCC 4.6 is chosen since it will be a dependency of Qt 5, so eventually the rest of KDElibs/KDE Frameworks will foolow suit.

Since GCC is the main targeted compiler, the library will be regularly tested against 4.6. For Clang, I’ll test with the latest version provided by Debian (currently 3.0).

With that said, I don’t expect that the library will really be uncompilable with older compilers, it is just that I have no intention keeping the compatibility and testing for it.

Service

For the service, the requirement will be more obvious – compilation will likely fail on older compilers. I’m currently pondering whether to require GCC 4.6 or 4.7. The later has some rather nice additions from C++11 standard (that are present in Clang 3.0) like Non-static data member initializers (N2756), Template aliases (N2258), Delegating constructors (N1986), Explicit virtual overrides (N2928, N3206, N3272).

I guess I’ll start of with 4.6 and see whether it is enough and whether I can live without a few adorable N****s :)

Edit: Regarding kde-core-devel – I will start this discussion on k-c-d once 4.9 is out of the door. The point of this post is to test the public responses. Don’t want to bother everybody on k-c-d for something that is not intended for this release.

See original: Planet KDE Modern compilers required [Activities after 4.9]